Writer

De Banane Atomic
Aller à la navigationAller à la recherche

Sommaire

Texte

Tabs et alignement du texte

Les Tabs permettent d'avoir différents alignement sur une même ligne.
Le style Header possède 3 Tabs: gauche, centre et droite.
Utiliser la touche Tab pour se placer sur le Tab suivant.
Ajouter un Tab: clique dans la règle. Clique-droit sur le texte → Paragraph → Tabs

Changer le level d'un paragraphe

Permet d'ajouter un paragraphe à l'index sans utiliser les Headings
Clique-droit → Paragraph → Outline & Numbering → Outline level

Écrire un point avec la touche point du pavé numérique

Tools → Options → Language Settings → Language → Decimal separator key → décocher « Same as locale setting »

Centrer verticalement le contenu d'une cellule

Format → Align → Center

Diviser une table sur 2 pages

Table → Split Table

Sauts de page

  • Ajouter un saut de page → Ctrl + Entrée
  • Supprimer un saut de page → RetArr
  • Supprimer un saut de page manuel situé avant un tableau:
    • Cliquez avec le bouton droit de la souris dans le tableau, puis choisissez Tableau.
    • Cliquez sur l'onglet Enchaînements.
    • Désactivez la case à cocher Saut.

Créer une table des matières

Insertion → Index et tables → Index et tables...

Masquer le numéro de page sur la première page

  1. Cliquer dans la première page
  2. Styles and formatting → formatting styles for pages
  3. Double-clique sur First Page

Barrer du texte

Sélectionner le texte → clique-droit → Style → Barré
Sélectionner le texte → clique-droit → Caractère → Effet de caractères → Barré :

  • Simple
  • Double
  • Gras
  • Avec /
  • Avec X

Passer un texte en majuscules

Séléctionnez le texte → clique-droit → Modifier la casse → MAJUSCULES

Retour à la ligne dans les puces

Ajouter un retour à la ligne tout en restant dans la puce courante : Alt + Entrée

Modifiez le style des puces

Permet de modifier la taille, la couleur et la police des puces sans modifier le style du texte.
Clique-droit → Puces et Numérotation → Options → Style de caractère
9 Tricks for Using List Styles in LibreOffice/OpenOffice.org

Modifier la taille de l'interligne

Paragraphe

Sélectionnez le paragraphe → clique-droit → Paragraphe... → Retraits et espacement

Style

Ouvrir la fenêtre Styles et formatage (F11) → clique-droit sur un style → Modifier... → Retraits et espacement → Interligne → Fixe

Espace insécable

Ctrl + Maj. + Espace

Lignes

  • Ligne fine : ---
  • Ligne moyenne : *** ____
  • Ligne épaisse : ~~~ ###

Les lignes correspondent aux bordures du bas du paragraphe. Pour changer leurs couleurs, tailles ou styles :
clique-droit sur la ligne → Paragraphe → Bordures

Insérer un caractère unicode

Ctrl + Shift + u → code du caractère

Caractère Code unicode
2260

Connaitre le code d'un caractère

Allez dans Calc → =UNICODE("a") → 97

Templates

Dossier

  • ~/.config/libreoffice/4/user
  • %AppData%\LibreOffice\4\user\template

File → Templates

Choisir le template par défaut

  1. File → New → Templates
  2. Sélectionner le template → Set as Default

Taille de la page

Format → Page → Page → Format = A5

Couleurs

Changer la couleur de l'arrière-plan

Changer la couleur « Arrière plan du document » de l'interface

La couleur d'arrière-plan ne sera pas imprimée ni exportée en PDF, elle est spécifique à l'application et ne modifie pas le document.

Supprimer les marges

Format → Page...

  • Page → supprimer les marges
  • Bordure
    • disposition des lignes → définir quatre bordures
    • espacement avec le contenu → définir les mêmes valeurs que celles des marges (2 cm)
    • couleur → la même que celle d'arrière plan

Ajouter une Frame

Insert → Frame

  • Type
    • Width → 21
    • Height → 29.7
  • Wrap
    • Settings → Through
    • Options → In background
  • Border → Set no borders
  • Background → couleur

Ajouter le frame dans le header permet de l'avoir sur toute les pages, mais prend un peu d'espace pour le header.

Changer la couleur des hyperliens

Tel qu'ils seront imprimés en pdf

Style et formatage → Styles de caractère → Lien internet

Tel qu'ils seront affichés

  • Outils → Options… → LibreOffice → Apparence → Liens visités
  • Tools → Options → LibreOffice → Application Colors → (Un)Visited Links

Dessin

Arrondir les angles d'un rectangle

  • Sélectionnez le rectangle
  • Affichez la barre d'outils Dessin (Affichage → Barres d'outils → Dessin)
  • Cliquez sur l'icône Points
  • Passez la souris sur l'angle haut droit du rectangle jusqu'à obtenir une main avec l'index vers le haut
  • Cliquez, puis déplacer la souris pour changer l'angle

Images

Marges autour des images

Clique-droit sur l'image → Options → Onglet Wrap → Spacing
Double-cliquez sur l'image pour afficher les options → Adaptation du texte → Espacement

PDF

Options d'export PDF

  • PDF/A-1a : norme d'archive PDF pour longue conservation
    • Toutes les polices utilisées dans le document sont incorporées
    • Pas de support de la transparence
  • Incorporer les polices standards : incorpore les 14 polices Postscript standards.
    • Courier (Regular, Oblique, Bold, Bold Oblique)
    • Helvetica (Regular, Oblique, Bold, Bold Oblique)
    • Symbol
    • Times (Roman, Italic, Bold, Bold Italic)
    • ITC Zapf Dingbats

Export as PDF

Les images SVG exportées en PDF sont de faible qualité

A priori c'est un bug, LO pixellise l'image SVG avant l'export PDF.
Contournement : remplacer l'image SVG par une image PNG de grande qualité (180ppp)

Dictionnaires

Installer un dictionnaire

  1. Aller sur le site des extensions et chercher les dictionnaires (Dictionnaires français, English Dictionaries)
  2. Télécharger le dictionnaire souhaiter (fichier *.oxt)
  3. Tools → Extension Manager → Add

GRAMMALECTE: dictionnaire français orthographe et grammaire

Bash.svg
# corriger l'erreur FileNotFoundError: [Errno 2] No such file or directory: '~/.config/libreoffice/4/user/uno_packages/cache/uno_packages/lu4169zea93.tmp_/Grammalecte-fr-v0.5.14.oxt/pythonpath/grammalecte/_dictionaries/french.bdic'
cd ~/.config/libreoffice/4/user/uno_packages/cache/uno_packages/lu4169zea93.tmp_/Grammalecte-fr-v0.5.14.oxt/pythonpath/grammalecte/_dictionaries
ln -s French.bdic french.bdic

Emplacement des dictionnaires

Standard $HOME/.config/libreoffice/3/user/wordbook/standard.dic
wordbook /usr/lib/libreoffice/share/wordbook/*.dic
myspell /usr/share/myspell/dicts/*.dic
hunspell /usr/share/hunspell/*.dic
hyphen /usr/share/hyphen/hyph_*.dic
Windows → %APPDATA%\libreoffice\4\user

Language Aids

Options

Tools → Options → Language Settings

  • Languages (User interface, Locale setting, Default Languages for Documents)
  • Writing Aids (language modules, dictionaries, options)

Autres

Raccourcis clavier

Raccourcis clavier Effet
Ctrl + 1 Titre 1

Barres d'outils

  • Ajout: View → Toolbars
  • Modification: Tools → Customize → Toolbars

Ouvrir le document en lecture seule

File → Properties → Security → Open file read-only

Basculer du mode édition au mode visualisation

Edit → Edit Mode (Ctrl + Shift + M)

Modifications

Permet d'enregistrer les modifications apportées à un document.
Edit → Track Changes → Record Changes

Insérer un commentaire

Ctrl + Alt + c ou Insertion → Commentaire

Modifiez les raccourcis clavier

Outils → Personnaliser → Clavier

Ligne de commande

Bash.svg
# Writer
libreoffice --writer [document.odt]

Bugs

Caractères accentués non imprimés

La police Nimbus Roman No9 L cause ce bug.
Changer de police règle le problème.