Inkscape

De Banane Atomic
Aller à la navigationAller à la recherche

Bases

  • Aligner / Centrer : Object → Align and Distribute... (Maj+Ctrl+A)
  • Selection multiple : avec Maj
  • Cercle, carrée ou redimensionner en conservant les proportions : Ctrl
  • Chemin → Union, Différence, ...

Dessin

Contour d'un carré

  1. Create rectangles and squares (F4) → utiliser Ctrl pour obtenir un carré
  2. Object → Fill and Stroke
    1. Fill → No paint
    2. Stroke paint → 000000ff (noir)
    3. Stroke style → Width → 1px

Transformer le contour en chemin

  1. Tracer un rectangle sans fond et avec un contour
  2. Edit → Duplicate Ctrl + D
  3. La copie du dessus étant sélectionnée, Fill and Stroke → Stroke paint → No paint
  4. On fait passer la copie en dessous, Object → Lower PageDown
  5. Sélectionner l’original → Path → Stroke to path
  6. On fait passer l'original en dessous, Object → Lower PageDown
  7. Sélectionner les 2 rectangle → Path → Difference Ctrl + -

Texte

Modifier la taille du texte, la police ou le style

Texte → Texte et police...

Caractères Unicode

Dans une zone de texte : Ctrl + u → code Unicode

Texte invisible avec Firefox

  • Sélectionnez le texte
  • Texte → Convertir en texte

Redimensionner la page au contenu

Fichier → Propriétés du document → Redimensionner la page au contenu → Ajuster la page au dessin ou à la sélection

Changer la couleur du fond de l'application

File → Document Properties → Page → Background (en bas) → Checkerboard background

Changer la couleur du fond de l'image

Xml.png
<svg version="1.1" xmlns="http://www.w3.org/2000/svg">
   <rect width="100%" height="100%" fill="red" />
   <!-- ... -->
</svg>

Inverser les couleurs

Extensions → Colors → Negative

Calques

  • Changer un objet de calque : Calque → Déplacer la sélection au calque supérieur / inférieur

Dégradés

Inverser un dégradé

  • Éditez le dégradé
  • Passez le canal Alpha du premier stop à 0
  • Passez le canal Alpha du deuxième stop à 255

Filtres

  • Shadows and Glows → Drop Shadow (Ombres portées)

Retirer un filtre

Filters → Remove Filters

Ligne de commande

Bash.svg
# export en PNG
inkscape -f image.svg -e image.png

Transformer une image Bitmap en image Vectorielle

  1. Ouvrir l'image Bitmap
  2. Sélectionner l'image
  3. Path → Trace Bitmap
    1. Décocher Smooth, flou Gaussian
    2. Cocher Remove Background, fond transparent
  4. Déplacer l'image vectorielle en arrière-plan: Object → Lower
  5. Supprimer l'image Bitmap
  6. Décomposer l'objet: Path → Break appart