Gimp

De Banane Atomic
Aller à la navigationAller à la recherche

Transparence d'un layer

  1. Sélectionner le layer
  2. Changer la valeur d'opacity en haut

Outils de mesure

Arrondir une image

Filters → Decor → Round Corners

Rotation de l'image

Image → Transform → Rotate

Améliorer une photo trop sombre

Les deux méthodes peuvent être utilisées en même temps pour un meilleur résultat.

Screen Mask

  1. Duplicate layer
  2. Add Layer Mask: Grayscale copy of layer + Invert Mask
  3. Mode → Screen

Contrast Mask

  1. Duplicate layer
  2. Colors → Desaturate → Average
  3. Colors → Invert
  4. Filter → Blur → Gaussian Blur → 15
  5. Mode → Soft Light
  6. Opacity → 75 (cette étape et les suivantes sont optionnelles)
  7. Duplicate layer
  8. Opacity → 50
  9. Duplicate layer (original)
  10. Mettre le layer au dessus des autres
  11. Mode → Darken Only
  12. Opacity → 15

Changer la taille du canvas et centrer l'image

Image → Canvas size

  • Width / Height
  • bouton Center
  • Resize Layers

Restaurer les positions des onglets

Édition → Préférences → Gestion des fenêtres → Restaurer les positions enregistrées aux valeurs par défaut

Masque

  • Clique-droit sur le calque → Dupliquer le calque
  • Clique-droit sur le calque du haut → Ajouter un masque de calque → Blanc
  • Outil pinceau → colorier sur le masque fais apparaître le calque du bas
    • Inverser les couleur (Noir / Blanc) pour corriger les dépassements
  • Réduire l'opacité du calque de haut pour réduire la désaturation
  • Inverser le masque: Couleurs → Inverser
  • Appliquer un dégradé sur le masque: Blend Tool

Créer un fichier ico

Pour que le fichier ico contienne plusieurs images, il faut:

  • créer plusieurs calques: Calque → Dupliquer le calque
  • redimensionner les calques: Calque → Échelle et taille du calque
  • exporter au format ico

Arrondir les coins d'une image

Filtres → Décoration → Coins arrondis.

Appliquez un filtre de couleur

Couleurs → Coloriser

Ne fonctionne qu'avec les images en mode RVB

Options de l'export PNG

  • Entrelacement
    L'entrelacement permet à une image de page Web de s'afficher progressivement lors du chargement, ce qui peut être utile avec un connexion lente, parce que vous pouvez interrompre le chargement d'images sans intérêt.
  • Enregistrer la couleur d'arrière-plan
    Si votre image possède plusieurs niveaux de transparence, les navigateurs ne sachant gérer que deux niveaux, utiliseront, à la place, la couleur d'arrière-plan de la Boîte à outils que vous aurez enregistrée en cochant cette option. Jusqu'à la version 6, Internet Explorer ne savait pas gérer la semi-transparence.
  • Enregistrer le gamma
    La correction du gamma est la capacité à corriger les différences d'interprétation des couleurs des ordinateurs. Elle enregistre, dans le PNG, l'information gamma qui reflète le facteur Gamma actuel de votre affichage. Les afficheurs sur d'autres ordinateurs peuvent alors compenser afin que l'image ne soit pas trop sombre ou trop claire.
  • Enregistrer le décalage de calque
    Le PNG possède une valeur de décalage appelée « oFFs chunk », qui fournit des données de position. Malheureusement, la prise en compte du décalage PNG par GIMP est défectueuse, ou du moins n'est pas compatible avec d'autres applications. N'activez pas les décalages, aplatissez les calques avant d'enregistrer et vous n'aurez aucun problème.
  • Enregistrer la résolution
    Enregistre la résolution de l'image, en ppi (pixel per inch = points par pouce)
  • Enregistrer la date de création
    Date à laquelle le fichier a été enregistré.
  • Enregistrer un commentaire
    Vous pourrez lire ce commentaire dans la Propriétés de l'image.
  • Enregistrer les valeurs de couleur pour les pixels transparents
    Quand cette option est cochée, les valeurs de couleurs sont enregistrées même si les pixels sont complètement transparents.
  • Niveau de compression
    La compression PNG étant sans perte, la seule raison d'utiliser un taux de compression inférieur à 9 serait une durée de compression trop longue avec un ordinateur lent. Rien à craindre non plus de la décompression, celle-ci étant aussi rapide quel que soit le niveau de compression.
  • Enregistrer les valeurs par défaut
    Cliquez pour enregistrer les paramètres courants. Ultérieurement, vous pourrez les récupérer grâce au bouton Charger les valeurs par défaut.

Effet bronzé

  1. Créez une nouveau calque (couleur de premier plan)
  2. Le remplir de la couleur du bronzage souhaitée
  3. Le passer en mode Lumière douce et réglez à nouveau la couleur et l'opacité (50) si besoin
  4. Ajoutez un masque de calque Noir
  5. Avec le pinceau appliquez la bronzage sur les zones souhaitées

Remplacer une tête sur un corps avec Gimp

Augmenter la netteté d’une photo

  1. Dupliquez deux fois le calque « arrière-plan » avec le bouton de duplication en bas de la fenêtre des calques.
  2. Floutez le calque du haut: Filtres → Flou → Flou Gaussien → 10 pixels.
  3. Passez le calque en mode « extraction de grain ».
  4. Fusionnez ce calque avec celui d’en dessous: clic droit sur le calque → Fusionnez vers le bas.
  5. Passez ensuite le calque obtenu en mode « fusion de grain ».

Flouter une image

Sélectionnez une partie de l'image → Filtres → Flou → Flou gaussien...

Touches utiles lors du dessin

  • Ctrl: transforme l'outil de dessin en color picker (pipette)
  • Maj: tracé rectiligne
  • Maj puis Ctrl: tracé rectiligne avec des angles multiples de 15°

Supprimer le fond d'une image

Sélectionner le fond à l'aide de l'outils de sélection contiguë (baguette magique). Il est aussi possible de sélectionner l'élément à garder et d'inverser la sélection. Supprimer la sélection. Si rien ne se passe, il faut ajouter un canal alpha au calque en cours.

Format XCF

Format natif de GIMP, permet de sauvegarder tous les éléments.

Découper la sélection

Image → Découper la sélection

Brosses / Brushes

Créer une brosse à partir d'un texte

  1. File → New → Advanced Options
    1. Color space: Grayscale (permet de changer la couleur de la brosse par la suite)
    2. Fill with: Transparency
  2. Text Tool → Écrire le texte
  3. Image → Autocrop image
  4. File → Export as → ~/.gimp-2.8/brushes/MaBrosse.gbr

Ajoutez des brosses

Copiez les brosses (dossier contenant des fichiers *.gbr) dans un des dossiers suivant:

  • ~/.gimp-2.x/brushes
  • /usr/share/gimp/2.x/brushes
  • %HOMEPATH%\.gimp-2.x\brushes
  • C:\Program Files\GIMP-2.0\share\gimp\2.0\brushes

Actualisez les brosses à l'aide du bouton recharger en bas de la fenêtre des brosses.
Puis sélectionner un outils de dessin (crayon ou pinceau) et une brosse pour pouvoir l'utiliser.

Appliquer une brosse

  1. Choisir l'outil Pencil ou Paintbrush
  2. Choisir la brosse
  3. Choisir la Size, la Color, l'Angle
  4. Appliquer la brosse dans un nouveau layer permet de la déplacer,de changer la Size et la Color

Une fois appliquée:

  • Changer la Size: Layer → Scale Layer
  • Changer la Color: Colors → Colorize

Watermark

  1. Créer une brosse contenant du texte
  2. File → Open as Layers → choisir le fichier watermak.gbr
    • Ou bien: New Layer → Paintbrush (color, size, angle) → MaBrosse → cliquer sur l'image pour appliquer la brosse → Layer → Autocrop layer
  3. Changer l'opacité

Effet texte gravé

  1. Sur un fond ni noir, ni blanc, écrire un texte en blanc.
  2. Clique-droit sur le layer du texte → Alpha to Selection
  3. Sélection du layer d'arrière plan → Filters → Map → Bump Map
    1. Bump map: le layer du texte
    2. Map type: linerar
    3. Compensate for darkening
    4. Invert bumpmap
    5. Azimuth: 135
    6. Elevation: 45
    7. Depth: 3
    8. Waterlevel: 0
    9. Ambient: 0
  4. Après avoir validé, masquer le layer du texte pour faire apparaître la gravure

Copier/Coller une image

Il se peut que l'image collée ait perdu ses couleurs.
Dans ce cas, pour l'image principale, aller dans Image → Mode et changez Couleurs indexées par RVB.

Alignement et distribution

  1. Sélectionner l'outil Alignment
  2. Relative To: Active Layer
  3. Mettre en layer actif le layer de référence
  4. Sélectionner le layer à déplacer ou les layers à répartir
  5. Choisir l'alignement ou la distribution

Guides

Permet de tracer des lignes sur lesquelles on pourra accrocher des objets, une image que l'on déplace par exemple.
Images → Guides
Supprimer un guide en le sortant de l'image.

Inverser les couleurs

Couleurs → Inverser

Convertir en noir & blanc

  • Image → Mode → Niveaux de gris
  • Couleur → Désaturer

Symétrie

Image ou calque → Transfomer → Mirroir horizontal ou vertical

Raccourcis / Shotcuts

  1. Edit → Preferences → Input Controllers

Changer la taille des brosses avec la molette

  1. Vérifier que Main Mouse Wheel est bien dans Active Controller
  2. Double-cliquer sur Main Mouse Wheel
  3. Vérifier que Enable this controller est bien coché
  4. Double-cliquer sur Scroll Up → search: increase → sélectionner: Tools → Increase Brush Size Relative
  5. Double-cliquer sur Scroll Down → search: decrease → sélectionner: Tools → Decrease Brush Size Relative